Home Internal Internal ping zu nais0ne-servern

This topic contains 3 replies, has 2 voices, and was last updated by LeXy LeXy 3 years, 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #893
    LeXy
    LeXy
    Participant

    da is in letzter zeit ja gehäuft beschwerden über den ping auf unserem server gab möchte ich an dieser stelle gerne mal etwas aufklärung betreiben: zum einen betrifft dies ‘komischer weise’ nur einige anbieter.

    dann kommt auch manchmal folgender bullshit zusammen – hier eintrace (d.h. welchen weg ein paket vom server zum eigenen rechner geht) von simon:

    [attachment=11]trace_simon.PNG[/attachment]

    so, nun die frage, warum das ganze über paris gerouted wird???

    wers wissen will (und auch wer nich) schaut sich sich BITTE mal folgendes video ab 45:16 an:

    https://www.youtube.com/watch?v=V_SMsAA7wcg

    LeXy^

    #1128
    LeXy
    LeXy
    Participant
    LeXy^ wrote:
    da is in letzter zeit ja gehäuft beschwerden über den ping auf unserem server gab möchte ich an dieser stelle gerne mal etwas aufklärung betreiben: zum einen betrifft dies ‘komischer weise’ nur einige anbieter.

    dann kommt auch manchmal folgender bullshit zusammen – hier eintrace (d.h. welchen weg ein paket vom server zum eigenen rechner geht) von simon:

    [attachment=11]trace_simon.PNG[/attachment]

    so, nun die frage, warum das ganze über paris gerouted wird???

    wers wissen will (und auch wer nich) schaut sich sich BITTE mal folgendes video ab 45:16 an:

    https://www.youtube.com/watch?v=V_SMsAA7wcg

    LeXy^

    ps. eigentlich soillte sich JEDER mal das ganze video ansehen!

    #1130

    Lexy,

    das mag sein das es das gibt aber die Server sind eins a gelaufen nur seit ca. 4 Wochen gibt so ne Ping Sprünge. Und das denkt sich keine aus um dich zu Ärgern sondern es sind Probleme bei mehren Leuten.
    Mann kann es Prüfen oder man lässt es.

    Deine Aussage war Prüft bitte die Server und wenn ihr Probleme habt melden. Das haben wir gemacht.

    Gruss Bote

    #1131
    LeXy
    LeXy
    Participant

    bote, und genau das hab ich ja gemacht. um sicher zu sein habe ich die Server mittlerweile auf zwei virtuellen Maschinen installiert – eine davon ist frisch aufgesetzt. bei beiden (und das ist auch logisch, da es die gleiche ip ist) routen manche Internet anbieter über das ‘level3’ in Frankreich oder polen und nicht über den deutsch ‘de-cix’.

    und glaub mir, da ich mich hier flankieren auskenne stinkt mir das natürlich besonders und ich hab versucht dem ganzen auf den grund zu gehen.

    fakt ist, dass die telekom und kabel Deutschland ‘random’ über andere Knotenpunkte routet, da ihre leitung zum de-cix (was der grösste Knotenpunkt in Europa ist) einfach nicht dick genug ist.

    leider kann ich den Server nicht einfach so umziehen, da hier unter anderem unsere corp Website und Cloud läuft und wir gerade hier eine gute Anbindung – nicht nur zu deutschen kunden, sondern auch der restlichen welt brauchen.

    daher gibt es temporär nur eine lösung: es mietet jemand einen 12 Slot Server bein einem drittanbieter.

    cheers

    LeXy^

    ps. das Video war nicht gedacht um irgend jemand ans bein zu pissen – vielmehr wollte ich hier mal etwas aufklärunbgs arbeit betreiben, da es wirklich mal sehr gut erklärt ist.

    wer ein bisschen tiefer einsteigen möchte kann sich hier https://www.de-cix.net/customers-partners/customers/de-cix-frankfurt/ mal anschauen, wer alles an dem ‘switch’ dran hängt – und ja, es ist auch kabel Deutschland und die telekom – nur halt komischer weise mit ner kleineren Leitung wie z.b. hetzner (was nur ein Rechenzentrum ist). d.h. alle deutschen kunden von kabel und der tk sind mit ner kleineren Leitung gepeert als die paar popeligen Server von nem rechenzentrum^^

    oder hier mal ein post (zware aus 2013 – aber sehr schön geschrieben) – und genau zu diesem Thema findet man tausende im netz:

    Quote:
    Speedprobleme bei Verbindungen via DECIX

    Zitat

    Beitragvon asmaps » 08.02.2013, 18:40

    Hallo zusammen,

    ich habe einen KD Anschluss mit 32 MBit. Leider musste ich feststellen, dass einige Verbindungen ziemlich lahmen (ca. 500-600KB/s). Ich hab dann mal ne Menge Forschung mit traceroute, speedtest.net, iptraf und ping betrieben und es liegt die Vermutung nahe, dass alle Verbindungen via Frankfurt/DECIX betroffen sind.
    Konkret:
    Der FTP-Server in Esslingen ( http://ftp-stud.hs-esslingen.de/info/ ), welcher eine sehr gute Bandbreite hat liefert mir nur 450-500KB/s, während ich gleichzeitig mit einem Rechner, der in Stuttgart auch ans BelWue angeschlossen ist (wo auch der Esslinger Server angeschlossen ist), mit 1 GBit/s (+/- 100MB/s effektiv) runterlade. Am Server kanns also nicht liegen. Traceroute sagt mir, dass nach einigen Hops innerhalb von KD (von Bamberg aus) in Frankfurt am DECIX das Paket ans Belwue übergeben wird. Von meinem Rechner in Stuttgart (bei dem ich auch keine höhere Bandbreite bekomme, obwohl der 1 GBit/s Upload hat) läuft das Paket den selben Weg, also auch die Rückrichtung geht übers decix.

    Auf speedtest.net habe ich noch etwas entdeckt: Bis vor kurzem lief das Signal von hier ins Hetzner-RZ Nürnberg auf ziemlich kurzem Weg dahin und scheint irgendwo hier in der Gegend über ein Peering direkt zu Hetzner (ohne DECIX also) gekommen zu sein. Da hatte ich auch Bandbreiten von +/- 30MBit, also alles in Ordnung und am Anschluss an sich scheint es nicht zu liegen. Vor einigen Stunden hat das Routing allerdings umgeschwenkt und mein Traffic zum selben Rechner im Hetzner RZ läuft plötzlich übers DECIX und siehe da ich bekomme auch da auf einmal nurnoch 10-15MBit…

    Der KD-interne Speedtest zeigt mir normalerweise auch Werte an, die in Ordnung sind – logisch, da der Traffic ja garnicht aus dem Netz rausgeht (also über DECIX o.ä.).

    Eine weitere Beobachtung war, dass ein Videostream von der Prosieben.de-Seite über Level3 in Berlin gepeert wurde und auch der lief flüssig in HD mit fast 900KB/s, also fast doppelt so schnell wie alles, was via DECIX kommt (schneller brauchte es ja nicht, weil das Video keine höhere Bitrate hat ;-) ).

    Diese Beobachtung hab ich noch mit vielen weiteren Verbindungen gemacht.
    DECIX -> lahm (+/-500 kBit/s)
    anderes Peering -> annähernd 32MBit

    Daher meine Frage, ob das noch jemand beobachtet hat und ob vielleicht schonmal jemand deswegen bei KD angerufen hat und eine Antwort von denen hat. So wie es jetzt ist macht es keinen Spaß, wenn die Hälfte aller Verbindungen rumlahmen…

    Grüße
    asmaps

    PS: Der Speedtest, den ich hier im Forum oft gesehen habe (http://speedtest.qsc.de/) liefert mir bei der Datei http://speedtest.qsc.de/100MB.qsc auch eine Geschwindigkeit in der Größenordnung 500-600 kBit/s (sogar oberes Ende *yeay*). Traceroute zeig mir, dass der Traffic am DECIX vorbeikommt (xxxx = Privacy ;-) ):

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.